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Nota: Si quieres regresar al Índice haz click sobre el Cubo en la parte superior derecha de cada página. 
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1.0 MAYA: PREPARANDO STATIC MESHES PARA UDK 
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MAYA: Preparación de Static meshes para UDK. 

1. Recuerda que si el mesh es un edificio necesitas dos Uv's: “map1(tilling)”, “UvSet (Únicas para LightMap)”. 

2. Usa  el archivo de referencia a este tema: “TL_FB_SteelGlass_001.mb” 
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 Map1: Son las UV’s con “tilling” para texturas que se puedan repetir escalando las uvs y no se note la repetición como;  

ladrillos, piedras, etc. 

 

 uvSet: son las texturas únicas que se hacen de todo el edificio, para que con estas se haga un “Ambient Occlusion” 

desde Maya o UDK. 
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MAYA: Formato de Materiales y Texturas para exportación. 

 El mesh necesita tener un material por cada textura que se vaya aplicar, y estos materiales deben de tener nombres descriptivos de 

lo que representara como textura.  

Materiales: 

o Nombres: Bricks, Concrete, Metal, Plastic, 

Windows, Unique, etc.  

o LightMap – Cada edificio tendrá un ambient 

occlusion conocido como light map; en este caso 

solo se agrega al final del nombre del material Eje: 
"TL_FB_SteelGlass_001_AO".  

Texturas: 

Al final se pone el sufijo que identifica que tipo de textura 

es: 

_D – Diffuse Map - (Color)  

_N – Normal Map - (relieves)  

_S – Specular Map - (brillos)  

_O – Opacity Map - (opacidad)  

_E – Emmisive Map - (emisor de luz)  
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1.1 MAYA: ActorX EXPORTAR A UDK 
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MAYA: Instalación del ActorX Tool de UDK. 

 El primer paso es exportar con el plug-in de ActorXTool.mll de Epic Games en Maya.  

 Este se debe de copiar en la carpeta de Mayax.x>bin>plug-ins para después mandar ejecutar el comando de axmesh; en la línea de comandos.  
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MAYA: Exportando Static Mesh de Maya a UDK 

 

Ahora seleccionando el mesh que se quiere exportar lo que hacemos es activar el axmesh; y nos aparecerá una ventana del ActorX, este 

guarda los archivos en extensión ASE: 

  

 

Nota: Puedes usar el “Deo’s Maya Tool” que tiene ya incorporado con una interfaz el poder exportar “Static Meshes” y “Skeletal Exporter”.  
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1.2 IMPORTANDO STATIC MESH EN UDK 
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UDK: Paso en UDK para Importar Static Meshes 

 

Abrimos el “Content Browser” e importaremos el mesh de Maya y las texturas cada una dentro de UDK. 
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Ahora se habrá creado una nueva categoría dentro de Tutorial que es Tutorial>Meshes donde quedara el edificio de Maya exportado en ASE. 

Texturas: “Compresion No Alpha:On” y “Defer Compresion: On” 

   



 

 
13 

www.3dboxweb.com 

 Este es el resultado de la importación de las texturas y el mesh en UDK. 

CREAR MATERIALES PARA LAS TEXTURAS (solo Diffuse).  
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1.3 “COLLISION” PARA STATIC MESHES EN UDK 
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Maya: Exportar mesh Collision. 

 

Necesitamos crear de un Static Mesh que partes colisionaran con los jugadores o armas, esto se hace por aparte del Mesh, para que el 

Engine no calcule cada una de las caras del “Static mesh” y se pueda optimizar el desempeño. 

Desde maya podemos crear la colisión, nada mas tienen que cumplir ciertas reglas: 

 Tienes que ser un objeto sin caras cóncavas. 

 No puede tener hoyos o caras eliminadas. 

 La terminación del nombre del mesh debe de ser: MeshNombre_UCX. 

 El mesh_UCX se debe de exportar junto con el “StatiMesh”. 
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UDK: Visualizar “Mesh Collision”. 

 

 Ahora importamos el archivo del edificio ASE en UDK y podemos ver el mesh. 

 Abrimos el mesh dando doble click sobre este en el “Content Browser” y abrirá el “Unreal Static Mesh Editor”,  ahora 

presionando el botón de “Show Collision” para poder visualizar el mesh de colisión que creamos desde Maya. 
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UDK: Crear Colisiones desde UDK. 

 

Si la colisión no se creó desde Maya, podemos crear una colisión de manera muy rápida, nada mas hay que tomar encuentra que para 

meshes con formas muy irregulares la mejor opción es hacerlo desde Maya, así podemos optimizar mas el numero de polígonos que tendrá 

así como la forma. 

Para esto abrimos el Static Mesh y en el menú de “Collision” tenemos varias opciones para generar desde UDK la colisión. 
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1.4 LOD (Low Object Distance) a UDK 
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MAYA: Exportar LOD de Maya a UDK. 

  

En esta versión solamente seleccionaremos el LOD y lo exportaremos con el ActorX por sepa  
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UDK: Visualizar LOD en UDK. 

 El LOD importado lo que nos permitirá será insertarlo y cambiarlo por el Mesh Base (B), y podemos agregar hasta 3 LOD [1, 2, 3]. 

 Una vez importando vamos “LODDistanceRatio” y aquí cambiamos a cuanta distancia cambiara por el mesh base o los LOD.  
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UDK: Crear LOD desde UDK. 

 

 Podemos crear desde UDK “LOD’s” de manera muy rápida y fácil, la desventaja es que no tenemos tanto control sobre la topología. 
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1.5 SKELETON MESHES 
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Formatos de Exportación “Skeletal Exporter”. 

 

 

Al exportar desde Maya con el ActorX, este exporta en formato: “PSA” y “PSK”, que son archivos binarios que contienen las animaciones 

primas y la malla (modelado) de información utilizados, para importar las animación de los esqueletos en el motor de UDK.  

 

Formato PSK: 

Este formato de archivos contiene: 

 Meshes. 

 Influencia de los “Joints” y los pesos sobre cada vértice de la malla. 

 La pose por default del mesh o personaje animado.  

 Puede contener los “BlendShapes” del mesh. 

Resumen: Contiene Mesh y los pesos de los vértices (Paint Wieghts) de los Joints. 

 

 

Formato PSA: 

Este formato de archivos contiene: 

 Nombre de huesos y Jerarquías de  los “Joints”. 

 Uno o más nombres de las secuencias de animación. 

 Movimiento y/o Rotación (Animación) de los mismos “Joints” 

Resumen: Contiene los Joints así como las animaciones esto es movimientos o rotaciones de los Huesos.  
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MAYA: Exportar animaciones con “Skeletal Exporter” 

 

 

  

 Usa los archivos de la carpeta: “ImportSkeletalMeshes”. 

 Tendrás acceso a un personaje descargado del sitio oficial de 

UDK, que viene completamente con Rigging y Controles. 
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MAYA: Pasos para Exportar “Skeletal Mesh” a UDK. 

1. Hay que girar hacia el eje de las “Z” el personaje, ya que este es el eje que tiene vertical UDK, así de esta manera no tenemos que 

girarlo o activar opciones extras desde UDK, selecciona el “MasterController” y en el AE cambia la opción de “Export UT3: On.” 

2. Ahora desde el ActorX  En “Browse” Seleccionamos la ruta donde ira el archivo, y en “Mesh file name” el nombre. 

 

 

 

 

 

 

 

 

  UDK: Pasos para Importar desde el ActorX de Maya. 

 

1. En “Content Broswer> Import”                                     seleccionamos el archivo y escribimos nombres “Package y Gorup”.           
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2. Ahora podemos dar doble click sobre el SkeletalMesh importado y nos abrire el “Unreal AnimSet Editor”. 

 

 
 

3. Automáticamente tendremos cargado nuestro personaje con un “Anim” por default, al cual podemos seleccionarle otros desde el 

Panel de “AnimSet” 
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1.6 BLEND SHAPES 
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MAYA: Crear Animaciones con “BlendShape” y exportarlo a UDK.  

 

1. Desde Maya abrimos el personaje y duplicamos la cara para poder hacer modificaciones y luego aplicar un BlendShape. 

2. Duplicamos el Mesh de la cara y desbloqueando sus “Channels”, hacemos deformaciones en los vértices y aplicamos un BlendShape. 

3. Ahora para no afectar al Skining que ya tiene el personaje, para esto moveremos el Input del BlendShape arriba del “skinCluster2”. 
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UDK: Importando “BlendShapes” a UDK. 

4.  Ahora eliminamos los otros meshes que creamos para los BlendShapes, para que estos no se exporten a UDK. 

5. Ahora giramos el personaje de nuevo en dirección del eje de las “Z” 

6. Ahora exportamos desde el ActorX, activando la casilla de “Exporta all blend shapes”. 

7. Ahora en UDK abrimos el “SkeletalMesh” del personaje que importamos en UDK. 
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8. Ahora vamos a la a la pestaña de “Morph” y crearemos un MorphTarget en el Menú “File>New Morph TargetSet…”  

9. Ahora con un Canal creado de Morph> “MorphTargetSet” en nuestro personaje, podemos cargar los BlendShapes. 

10. Seleccionamos en el Menú  “File>Import Morph Target…” y cargamos los archivos *.PSK y le asignamos un nombre a cada Blend.  
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1.7 ANIMATION EXPORTER 
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MAYA: Crear una animación y exportarlo a UDK.  

 

1. Lo primero es siempre crear en el frame 1 un “KeyFrame” para dejar almacenada la pose inicial. 

2. Creamos la animación que necesitamos en el personaje y lo exportamos con el ActorX. 

3. Giramos el personaje en el eje de las “Z” y activamos el ActorX. 

4. Llenamos los parámetros en “Animation Exporter”  “Digest Animation”. 
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5. Ahora procesada la animación y creado el ciclo en ActorX, ahora presionamos el botón de “Animation Manager” ´guardar la 

animación. Este paso se puede hacer múltiples veces ya que ActorX ira guardando las animación de los frames que nosotros le 

vayamos indicando, para después organizarlas en el Manager Panel. 

6. Ahora seleccionamos en “Animations” “Personaje_Animacion” --> y la pasamos a “Output Package”. 

7. Ahora está listo el paquete de animación para ser guardado, “Save As…” y lo guardamos en Formato: “*.SPA” 
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UDK: Importar animación en el “Skeletal Mesh”. 

 

1. Abrimos en “Content Browser” y abrimos el “Skeletal Mesh>PersonajeUDK”. 

2. En la pestaña de Mesh > Skeletal Mesh: PersonajeUDK. 

3. Cambiamos a la pestaña de “Anim” activamos en el Menu>File>New Ani  mSet, para tener un canal de animación vacio. 

4. Ahora tenemos en nuestro personaje en un”AnimSet” la animación SPA en el nuevo canal creado, podemos dar play. 

5. Veremos que la animacion no reproduce bien, esto es porque necesitamos ir en el Panel de “Properties>AnimSet” y desactivamos 

la opcion de “Anim Rotation Only” y ahora la reproduccion de la animacion y el mesh estan como en Maya se hizo.     
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1.8 SKELETAL MESH ACTOR – ANIMSET 
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UDK: Skeletal Mesh Actor – Animation  Set. 

 

Ahora para agregar personajes dentro de la escena y estos tenga cargados Tenemos Skeletal Meshes a los cuales podemos cargar 

animaciones (AnimSet), para el estado inicial del personaje. 

 

1. Abrimos la escena “1_8_SkeletalMesh_AnimSet.udk!” abrimos el Content Browser y vamos a “Object Type” y activamos “Skeletal Meshes” y 

seleccionamos el “SK_CH_ironGuard_MaleA” y lo agregamos a la escena. 

2. Con el personaje seleccionado abrimos el Panel de propiedades y accedemos al menú de SkeletalMeshActor>Skeletal Mesh Component>Anim Set 
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3. Abrimos el “Content Browser” y en filtros seleccionamos solamente “Animation Sets”… seleccionamos el “K_AnimHuman_BaseMale”, 

Agregamos un nuevo ítem        en “Anim Sets” del personaje y ahí cargamos  el AnimSet  seleccionado. 
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4.   Abrimos el menú “Animations>AnimNodeSeuqence> AnimNodeSeuqence” y aquí va el clip que queramos cargar al inicio del personaje en la escena. 

Nota: Activamos la opción de Playing? Y Lopping? = reproducir automáticamente y ciclado continuo. 

 


